Krzysiek Borek19.11.2017
Apple przestanie przyjmować aplikacje oparte o starsze SDK dla Apple Watch

Apple przypomniało dzisiaj programistom, że powinni wziąć pod uwagę nowości zawarte w watchOS 4 podczas tworzenia aplikacji dla inteligentnego zegarka.

To nie wszystko, bo programiści zostali poinformowani o braku kompatybilności aplikacji tworzonych w czasie wydania pierwszej wersji watchOS. Od 1 kwietnia przyszłego roku  aktualizacje aplikacji muszą być oparte o SDK watchOS 2 lub nowsze. W przypadku tworzenia aplikacji od podstaw, wymogiem ich pełnego i bezproblemowego działania jest oparcie ich o SDK watchOS 4 lub nowszy.

Od czerwca 2016 roku zaczęto wymagać SDK watchOS 2 do pisania aplikacji i aktualizacji obecnych. Jeżeli autorzy aplikacji nie zaktualizują ich na zasadzie nowego SDK (przynajmniej watchOS 2), to użytkownicy nie będą w stanie ich pobrać.

Aplikacje oparte o nowsze SDK będą w stanie wykorzystać pełnię możliwości Apple Watcha, więc programiści tworzący natywne aplikacje powinni mieć to na uwadze.

Polub nas na Facebooku, obserwuj na Twitterze, dodaj do Google+ lub RSS

The Sins never die

@krzysiek_borek