Krzysiek Borek25.01.2018
macOS 10.13.4 beta informuje użytkownika o niekompatybilnych aplikacjach

Wczoraj Apple udostępniło pierwszą wersję testową macOS 10.13.4 High Sierra, a jedną z najnowszych funkcji systemu jest wyświetlanie komunikatów o niekompatybilnych (32-bitowych) aplikacjach podczas ich uruchomienia.

Sytuacja jest podobna do iOS 11, który na dobre porzucił wsparcie dla starszych aplikacji.

To dopiero początek pozbycia się 32 – bitowych aplikacji dla macOS, a Apple nie wspomniało kiedy to nastąpi. Jednak dodanie komunikatu sprawia, że autorzy nie współpracujących z systemem operacyjnym aplikacji, powinni je zaktualizować. Wydaje mi się, że będą na to mieli maksymalnie dwa lata.

Obecnie komunikaty będą wyświetlać się jedynie programistom, piszącym aplikacje dla macOS, wiosną zaczną pojawiać się dla szerszej rzeszy użytkowników. Treść komunikatu będzie podobna do tego z iOS, więc system poinformuje użytkownika, że dana aplikacja może nie działać stabilnie i autor powinien ją zaktualizować.

Na razie 32-bitowe aplikacje nie przestaną działać, ale czuję, że wielu programistów się wścieknie, ponieważ będą musieli przystosować oprogramowanie do wytycznych Apple. Jeżeli tego nie zrobią to prędzej czy później ich aplikacje przestaną działać. Ponadto programiści w grudniu zeszłego roku otrzymali informację, że od stycznia 2018 roku programy dla macOS muszą być 64-bitowe. Dzięki temu Apple powinno szybciej uporać się z wyłączeniem wsparcia dla 32-bitowych aplikacji.

Pamiętajcie, że Mac App Store to nie jedyne miejsce, w którym można pobierać lub kupować interesujące was aplikacje. Właśnie dlatego przejście na 64-bitowe aplikacje może potrwać dłużej w porównaniu do iOS.

Źródło: redmondpie.com
Polub nas na Facebooku, obserwuj na Twitterze, dodaj do Google+ lub RSS

The Sins never die
@krzysiek_borek