Krzysiek Borek12.04.2018
watchOS 4.3.1 poinformuje użytkownika o niekompatybilnych aplikacjach

Pierwszą zauważalną zmianą w kompilacji testowej watchOS 4.3.1 jest zupełnie nowe powiadomienie. Pojawi się wyłącznie w momencie, gdy któraś z obecnych na zegarku aplikacji przestanie być kompatybilna z watchOS.

Dotyczy to wyłącznie aplikacji przygotowanych w oparciu o SDK watchOS 1. Właśnie wtedy ujrzycie powiadomienie z nazwą aplikacji ostrzeżeniem o nadchodzącym braku wsparcia.

This app will now work with future versions of watchOS. The developer of this app needs to update it to improve its compatibility.

Na ten moment ciężko stwierdzić, czy usunięcie wsparcia dla przestarzałych aplikacji pojawi się już w watchOS 5, który powinien zostać zapowiedziany podczas tegorocznego WWDC. Być może Apple się na to nie zdecyduje i ujrzymy to dopiero w kolejnej większej aktualizacji dla systemu operacyjnego Apple Watch.

Na szczęście w tym momencie stuknięcie na OK pod powiadomieniem sprawi, że aplikacja się uruchomi. To oznacza, że watchOS 4.3.1 pozwoli na uruchomienie przestarzałej wersji. Od pierwszego kwietnia aktualizacje dla obecnych aplikacji mają być wydawane w oparciu o SDK watchOS 2, podczas gdy nowe wymagają watchOS 4.

iOS 10.3 posiadał podobne powiadomienie, ale przejście na wyłącznie 64-bitowe aplikacje miało miejsce dopiero po wydaniu iOS 11.

Co sądzicie o nadchodzącej zmianie?

Źródło: idownloadblog.com
Polub nas na Facebooku, obserwuj na Twitterze, dodaj do Google+ lub RSS

The Sins never die
@krzysiek_borek